
About Image2SWF

Thank you for choosing Image2SWF. Image2SWF is an extremely easy program to convert your image 
files to Macromedia Flash Movie (SWF) files.

Image2SWF creates SWF files to be played with the Macromedia Flash Player. The latest Flash Player 
can be downloaded for free from Macromedia's web site at http://www.macromedia.com. 

http://www.macromedia.com/


System Requirements

Macintosh Requirements 

●     Power PC based Macintosh or greater 
●     Macintosh OS X or higher 
●     128 MB of RAM 
●     At least 50 MB of available hard disk space 
●     QuickTime 5.0 or higher* 

Windows Requirements 

●     Pentium processor-based PC or compatible computer 
●     Windows 98/ME/2000/XP 
●     128 MB of RAM 
●     At least 50 MB of available hard disk space 
●     QuickTime 5.0 or higher (Choose recommend Installation)* 
●     Macromedia Flash Player 5.0 or higher** 

* The latest QuickTime can be downloaded for free from Apple's QuickTime website at http://www.
quicktime.com 
** The latest Macromedia Flash Player can be downloaded for free from Macromedia's website at http://
www.macromedia.com 

http://www.quicktime.com/
http://www.quicktime.com/
http://www.macromedia.com/
http://www.macromedia.com/


Getting Started

Below is a brief description and steps to start you to convert your images with Image2SWF. 

Add image files to convert
To start using Image2SWF you need to add image files that you wish to convert. You can add image 
files by browsing for them by click the "Add" button in the Image2SWF window, selecting "Add..." 
from the "Image" menu or dragging and dropping image files onto the Image2SWF window. Click here 
for more information on Adding/Removing video files. 

Customize the conversion settings 
Use the "Settings" window to customize various properties for the conversion process. You may bring 
up the "Settings" window at any time by choosing "Settings..." from the "Image" menu or the 
toolbar. 

Export/Publish the image 
When you're ready to convert your image files, you will need to do an export. , export or publish the 
slide show by choosing "Export..." or "Publish from the "File menu. Click here for more information 
on publishing the images. 



Add/Remove Image files to the Job List for converting

Adding Image Files to the Job List 

Image files may be added to the jobs list by: 

●     Selecting "Add..." from the "Image" menu. 
●     Clicking on the "Add" button on the main window. 
●     Drag and drop a image file(s) onto the main window. 

Supported image file types include BMP, GIF, JPEG, PDF (Mac OSX), Photoshop (PSD), PICT, PNG, 
Targa (TGA), TIFF.

Removing Image Files from the Job List 

Select the entry from the list you want to remove. Then click the "Remove" button or choose 
"Remove" from the "Image" menu. You can also choose "Remove All" to remove all jobs from the 
list. 



Publish/Export Images 

When you're ready to deliver your images to an audience, you must publish or export the images to 
another format for playback. 

Export 

Exporting the images will encode your images to the specified output format. You can choose to export 
as a SWF or Multiple Formats at once. To export your images, select "Export" or "Export All" from 
the "File" menu or the toolbar. 

Multiple Formats 

The "Multiple Formats " option lets you specify multiple formats to export your video. 

●     Flash Movie - a Flash Movie (SWF) file. 
●     HTML - a HTML document to display the Flash Movie file. 
●     Macintosh Projector - a self executable Flash movie to run on Macintosh compatible computers 

without the need for the Flash Player to be installed on the users computer. 
●     Windows Projector - a self executable Flash movie to run on Microsoft Windows compatible 

computers without the need for the Flash Player to be installed on the users computer. 

To output your image as multiple formats, select "Multiple Formats " from the "Format" drop down 
list in the General tab. Click the Settings... button to specify the formats you want to output. 

Multiple Formats Publish Settings 

This is where you specify which formats to output and their settings.



 
Click "OK" to save the current publish settings and close the Publish Settings dialog box. 
Click "Cancel" to close the Publish Settings dialog box without saving the current settings. 

Formats 



 
Output To: Displays the path where all published files will be saved to on disk. 
Browse: Click to specify a different location to save the published files to. 
Type: Check the filetypes you want to publish 
Filename: The filename to save the published files in the Output to location. 

HTML 



 

●     "Dimensions" 
●     "Playback" allows you to set options to control the movie's playback and features 

❍     "Paused at start" pauses the movie until a user click a button in the movie or chooses 
Play from the shortcut menu. 

❍     "Loop" repeats the movie when it reaches the last frame. 
❍     "Display Menu" displays a shortcut menu when the user right-clicks (Control + click) the 

movie. 
❍     "Device Font" will substitute anti-aliased system fonts for fonts not installed on the user's 

system. Using device fonts increases the legibility of type at small sizes and can decrease 
the movie's file size. 

●     "Quality" will set the playback quality to determine the trade-off between processing time and 
applying anti-aliasing to smooth each frame before it is rendered on the viewer's screen. 

❍     "Low" favors playback speed over appearance and does not use anti-aliasing. 
❍     "Auto Low" emphasizes speed at first but improves appearance whenever possible. 

Playback begins with anti-aliasing turned off. If the Flash Player detects that the processor 
can handle it, anti-aliasing is turned on. 

❍     "Auto High" emphasizes playback speed and appearance equally at first but sacrifices 
appearance for playback speed if necessary. Playback begins with anti-aliasing turned on. 
If the actual frame rate drops below the specified frame rate, anti-aliasing is turned off to 
improve playback speed. 



❍     "Medium" applies some anti-aliasing, but does not smooth bitmaps. It produces a better 
quality than the Low settings, but lower quality that the High settings. 

❍     "High" favors appearance over playback speed and always uses anti-aliasing. If the 
movie does not contain animation, bitmaps are smoothed. If the movie has animation, 
bitmaps are not smoothed. 

❍     "Best" provides the best display quality and does not consider playback speed. All output 
is anti-aliased and bitmaps are always smoothed. 

●     "Window Mode" allows you to set options for transparency, positioning, and layering of the 
Flash movie. This option is not compatible with all browsers. 

❍     "Window" plays a Flash Player movie in its own rectangular window on a web page, for 
the fastest animation. 

❍     "Opaque Windowless" moves elements behind Flash movies to prevent them from 
showing through 

❍     "Transparent Windowless" shows the background of the HTML page on which the 
movie is embedded through all transparent areas of the movie, but may slow animation. 

●     "HTML Alignment" allows you to position the Flash movie window within the browser 
window. 

❍     "Default" centers the movie in the browser window and crops edges if the browser 
window is smaller than the movie. 

❍     "Left, Right, Top, Bottom" aligns the movie along the corresponding edge of the browser 
window and crops the remaining three sides as needed. 

●     "Scale" allows you to place the movie within specified boundaries. 
❍     "Default (Show All)" displays the entire movie in the specified area without disortion 

while maintaining the original aspect ratio of the movie. 
❍     "No Border" scales the movie to fill the specified area and keeps the movie's original 

aspect ratio without distortion and crops if needed. 
❍     "Exact Fit" displays the entire movie in the specified area without preserving the original 

aspect ratio, which may cause distortion. 
●     "Flash Alignment" allows you to set how the movie is placed within the movie window and 

how it is cropped, if necessary. 
❍     "Left, Center, Right" are used for horizontal alignment. 
❍     "Top, Center, Bottom" are used for vertical alignment. 

Projectors 



 

Fullscreen: If checked, the Projector will run in full screen mode when launched. While in full screen 
mode during playback, the user can hit the Escape key to exit the full screen mode. 
Allow Scale: If checked, the movie will scale to the size of the window 
Show Menu: If checked, the contextual menu will be enabled.

Expire On: If checked, the projector will expire on the specified date and display your custom Message. 
Message: The message to display when the projector expires. 



Save/Load Projects

Saving Image2SWF Projects 

You can save the settings for your current session to a Image2SWF Project file (.i2s) by choosing "Save 
Project" or "Save Project As..." from the "File" menu or toolbar. To overwrite the current project file, 
choose "Save Project". To save the file in a different location or with a different name, choose "Save 
Project As...". 

Please note that the project file does not save any images used in the project. If you move or delete any 
of the files used in the project, Image2SWF will not be able export the files properly. 

Loading Image2SWF Projects 

You can load and previously saved Image2SWF Project file (.i2s) by choosing "Open Project" from 
the "File" menu or toolbar. 



Image2SWF

The Image2SWF window is the main window and is where you add and remove the source files you wish to 
encode. 

 

Add...: Choose a source image file to encode. After choosing a source file, it will be added to the list of jobs to 
encode. You can also add image files by choose Add... from the Image menu or by dragging and dropping 
image files onto the Image2SWF window. 
Remove: Remove the current selected job from the list.
Remove All: Remove all jobs from the list.
Export: Encodes the current selected job from the list.
Export All: Encode all jobs from the list. 



Source

The Source window will display your source image where you can view and edit the image for 
encoding. 

 

Cropping

If in the Edit tab the "Crop" option is checked, you have the ability to choose an area of the image to 



encode. A crop box will appear that you can drag and resize to choose the area to crop. 



Settings

The Settings dialog allows you to customize the output settings for the current selected image. 

 



General

The General tab allows you to set the basic input and output settings. 

 

Input

The "Input" area allows you to specify the input source image you wish to convert. 



 

Path: The full path of the source image file to convert will be displayed here.
Browse...: Click to choose a different image video file. 

Output

The "Output" options allow you to specify the general settings for the output. 

 

Path: The full path of where the converted file will be saved to will be displayed here.
Browse...: Click to choose a different location to save the converted file to.

Format: Choose which format you wish to convert the source image file to. 

●     SWF: The Macromedia Flash file format to be played back in the Macromedia Flash Player. 
●     Multiple Formats...: Output multiple file formats at the same time. Choose from SWF, HTML, 

and Projector files. Click the Settings... button to specify the formats you wish to output. 

Preset: You can choose a pre-defined preset from the list, which will automatically set the settings for 
you. If you want to use your own settings, choose None.

Frame Rate: The frame rate (frames per second) of the converted SWF file.



Width: The width in pixels of the SWF file.
Height: The height in pixels of the SWF file.
Match image dimensions: If checked, the Width and Height will automatically be filled in to match the 
dimensions of the image dimensions from the Image tab. 
Bg Color: The background color of the swf file. 

Protect: If checked, Macromedia's Flash Authoring Tool will not be able to import the exported .swf 
file. 
Compress: If checked, the exported .swf file will be compressed. To playback compressed .swf files, 
the viewer will need version 6 or higher of the Flash Player.
Disable Printing: If checked, the Print option from the Flash Player will be disabled. 



Image

The Image tab allows you to see the properties of the image source and set the output quality settings. 

 

Input Propertes

The "Input Properites " displays various properties of the input image source. 



 

Format: The format of the image source.
Dimensions: The dimensions of the image source.
Color Depth: The color depth of the image source.

Output Settings

The "Output Settings " allows you to choose various settings to control the quality of the encoded 
image. 

 

Export: 

●     Jpeg: Compresses the source image as a jpeg. 
●     Jpeg w/ Alpha Channel: Compessess the source image as a jpeg with an alpha channel from the 

source image. 
●     Jpeg Import Data: Uses the existing jpeg data from the source file. The source file needs to be a 

non-progressive jpeg. 
●     Lossless 24 bit: Exports the image as 24bit RGB bitmap. 
●     Lossless 24 bit w/ Alpha Channel: Exports the image as 24bit RGB bitmap with an alpha 

channel from the source image. 
●     Lossless 15 bit: Exports the image as a 15bit RGB bitmap. 
●     Lossless 8 bit: Exports the image as a RGB bitmap using a 256 24bit color lookup table. 



Quality: The desired output quality if using Jpeg or Jpeg w/ Alpha Channel. Higher values will result in 
higher quality, but larger file sizes. 

Width: The output Width of the image.
Height: The output Height of the image.
Keep Aspect Ratio: If checked, the Width and Height will automatically keep the original aspect ratio 
of the source image.



Edit

The "Edit" tab allows you to edit the image for encoding. 

 

Filter

The "Filter" options allow you to apply effects to the image. 



 

Filter...: You can choose a filter to apply to the image source. After choosing a filter from the list, you 
can see a preview in the Source window.
Revert: Click to revert the image back to it's original state. This will remove any filters or crop settings 
applied.
Flip Horizontal: Click to flip the image horizontally.
Flip Vertical: Click to flip the image vertically.

Crop

The "Crop" options allows you to choose a specified area of the image to encode. 

 

Crop: Check if you wish to crop the image source. If checked, you can change the area to crop by 
changing the L,T,R,B values, or by dragging and resizing the crop box in the Source window.
L: The Left boundary to crop.
R: The Right boundary to crop.
T: The Top boundary to crop.
B: The Bottom boundary to crop.

Overlay

The "Overlay" options allows you to add an image to display on top of the encoded image. 



 

Use overlay: Check if you want to add an overlay/watermark to the encoded image. Click the Settings... 
button to customize the Overlay.



Watermark Settings

The Watermark Settings allows you to set the settings for your watermark/overlay.

 

Browse...: Click to choose an image you wish to use for your watermark. The filename of the current 
watermark to be used will be displayed to the right of the button. 

Width: The width in pixels at which you want the watermark to be displayed.
Height: The height in pixels at which you want the watermark to be displayed.
Keep aspect ratio : If checked, the dimensions will automatically maintain the original aspect ratio.

X: The horizontal position in pixels at which you want the watermark to be displayed. 
Y: The vertical position in pixels at which you want the watermark to be displayed. 
Align to document : If checked, you can choose to automatically align the watermark to the video in 
specified locations.

Use transparent color : Check this option if you wish to mask off (become transparent) a particular 
color in your watermark image. Choose a color you wish to mask off by clicking the color button to 
choose a color. 
Alpha: Choose a transparency level for the watermark.



FX

The "FX" tab allows you to add an effect to display and remove the image.

 

Effect In/Out 

Effect In: Choose an effect to use to display the image on the screen. If you do not wish to use an effect, 



choose "None" from the drop down list. 

Effect Out : Choose an effect to use to remove the image from the screen. If you do not wish to use an 
effect, choose "None" from the drop down list. 

Duration: The number of seconds to take to complete the specified effect.



SWF

The SWF tab allows you to customize the how the SWF file will playback. 

 

Movie Start Action

The "Movie Start Action" options allows you to specify how the image will begin to playback. 



 

Play Automatically: Start playing the SWF as soon as it is loaded into the Macromedia Flash Player. 
Play After Pause: Start playing the SWF after the desired number of seconds has elapsed. 
Stop on First Frame: Load the SWF into the Macromedia Flash Player and then stop until there is user 
interaction to contiue playing the SWF. 
Click to begin: Load the SWF into the Macromedia Flash Player and then stop until the user clicks on 
the SWF to continue playback.

Preload: Allows you to add a preloader to the image. If this option is chosen, a progress bar will be 
displayed showing the percentage of the image that has been downloaded/loaded into the Macromedia 
Flash Player. When the desired percentage of the SWF file has been loaded, playback of the image will 
begin. This option is helpful to allow smoother playback on slower internet connections. Click the 
Settings... button to customize the preloader. 

Loop

The "Loop" options allows you to choose the number of consecutive times the image will play. 

 

Play Once: Play the entire SWF and stop after the last frame is reached. 
Loop: Repeat the SWF the desired number of times and then stop. 
Play Forever: Continually play the entire SWF. 



Mouse Click Action

The "Mouse Click Action " option allows you to specify an action to take when the user mouse clicks 
the Macromedia Flash Player while the SWF is playing. 

 

Action: The action to take when the user mouse clicks on the image. 

●      None: No action to take.
●      Get URL: Loads a standard URL (eg. http://www.verticalmoon.com)
●      Load SWF: Loads an external SWF file (eg. another.swf)

Target: If the Action is Get URL or Load SWF, you can specify the target to load the URL/SWF to. 

●      Custom: Specify your own target
●      Pop-Up Window: Loads the URL/Path to a pop-up window. When choosing this option a 

Settings... button will appear to customize the Pop-Up Window Settings. For the pop up window 
to work properly you will either need to export both the .swf and .html files from the "Publish 
Settings..." or add the following javascript code to your html file that displays the .swf file 
between the <HEAD> and </HEAD> tags.
<SCRIPT language="JavaScript">
function VM_Popup(theURL, winName, winFeatures) {newWin=window.open(theURL, 
winName, winFeatures); }
</SCRIPT> 

●      _blank: Creates a new browser window and loads the URL/Path into it.
●      _parent: Removes the current frameset and loads the URL/Path in its place. Use this option if 

you have multiple nested framesets, and you want your URL to replace only the frameset in 
which your movie resides.

●      _self: Loads the URL/Path into the same frame or window as the current movie. 
●      _top: Loads the URL/Path into the current browser and removes all framesets in the process. 

Use this option if your movie is in a frame, but you want your linked URL to load normally into 
the browser, outside the confiness of any frames.

Movie End Action



The "Movie End Action" option allows you to specify an action to take when the SWF ends. 

 

Action: The action to take when the SWF ends. 

●      None: No action to take.
●      Get URL: Loads a standard URL (eg. http://www.verticalmoon.com)
●      Load SWF: Loads an external SWF file (eg. another.swf)
●      Unload SWF : Cause the Flash Player to unload the SWF from the player when it ends. This 

option causes the SWF file to be removed from RAM. 

Target: If the Action is Get URL or Load SWF, you can specify the target to load the URL/SWF to. 

●      Custom: Specify your own target
●      Pop-Up Window: Loads the URL/Path to a pop-up window. When choosing this option a 

Settings... button will appear to customize the Pop-Up Window Settings. For the pop up window 
to work properly you will either need to export both the .swf and .html files from the "Publish 
Settings..." or add the following javascript code to your html file that displays the .swf file 
between the <HEAD> and </HEAD> tags.
<SCRIPT language="JavaScript">
function VM_Popup(theURL, winName, winFeatures) {newWin=window.open(theURL, 
winName, winFeatures); }
</SCRIPT> 

●      _blank: Creates a new browser window and loads the URL/Path into it.
●      _parent: Removes the current frameset and loads the URL/Path in its place. Use this option if 

you have multiple nested framesets, and you want your URL to replace only the frameset in 
which your movie resides.

●      _self: Loads the URL/Path into the same frame or window as the current movie. 
●      _top: Loads the URL/Path into the current browser and removes all framesets in the process. 

Use this option if your movie is in a frame, but you want your linked URL to load normally into 
the browser, outside the confiness of any frames.



Preloader Settings

The Preloader Settings dialog allows you change the settings for a preloader.

 

Preloader 

Preload %: The percentage of the file you wish to preload before attempting to playback the swf file.
Message: Any message you wish to display while the file is being preloaded.
Font: The font to use for the Preload % and Message.
Font Color: The color to use for the Preload % and Message text.

Import Preloader from SWF, Lock & Load

Import...: Allows you to choose a SWF, Lock & Load project file (.lkl) to import.
Edit...: Launches SWF, Lock & Load to allow you to further edit the SWF, Lock & Load project file.
Remove: Removes the current SWF, Lock & Load project file chosen for import.

http://www.verticalmoon.com/products/swflockload


Pop-Up Settings

The Pop-Up Settings dialog allows you to customize the pop-up window

 

W: The width of the pop up window.
H: The height of the pop up window.
X: The horizontal position to display the pop up window.
Y: The vertical position to display the pop up window.

Resizable: Specifies whether or not the user may resize the popup window.
Scrollbar: Specifies whether horizontal and vertical scrollbars should be added to the pop up winodw. 
Most browsers will display the scrollbars only when needed to view content beyond the window area.
Toolbar: Specifies whether the toolbar should be shown. The toolbar contains the browser's navigation 
buttons such as Back, Forward, Reload, and Home.
Directory Bar: Specifies whether the directory bar should be shown. 
Status Bar: Specifies whether the status bar should be shown. The status bar area contains the security 
inidicator and status bar messages.
Location Bar: Specifies whether the location bar should be shown. The location bar is where the URL 
of the current page is shown.
Menu Bar: Specifies whether the menu bar should be shown. The menu bar contains the browser's 
menus such as File, Edit, and View. 

In order for the pop up window to function properly, you must add the following javascript snippet to 
your HTML code. You can copy and paste the following anywhere between the <HEAD> and </
HEAD> tags which should be located towards the top of the HTML code.



<SCRIPT language="JavaScript">
function VM_Popup(theURL, winName, winFeatures) {
newWin=window.open(theURL, winName, winFeatures);
}
</SCRIPT> 



Frequently Asked Questions

What is a SWF file?
The Macromedia Flash file format (SWF) (pronounced "swiff") delivers vector graphics and animation 
over the Internet to the Macromedia Flash Player.

What platforms are supported for Macromedia Flash playback?
Macintosh OS 9.x, OS 10.x
Windows 98, ME, 2000, XP

How many people have the Macromedia Flash Player installed?
The Macromedia Flash Player is installed on over 97% of Internet-enabled desktops worldwode and a 
wide range of popular devices.

What version of the Flash Player are the SWF files exported from Image2SWF compatible with?
The SWF files produced are compatible with the Flash Player version 6 and up. If you are publishing 
Projector files, the Flash Player is not needed.

What file formats are supported for importing?
BMP, GIF, JPEG, Photoshop (PSD), PICT, PNG, Targa (TGA), Tiff.



Contact Us

E-mail: 
support@verticalmoon.com 

Web: 
http://www.verticalmoon.com/support 

mailto:support@verticalmoon.com
http://www.verticalmoon.com/support
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